Open Redirect Affecting github.com/bitly/oauth2_proxy package, versions <2.2


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMBITLYOAUTH2PROXY-50013

  • published

    26 Mar 2016

  • disclosed

    26 Mar 2016

  • credit

    Unknown

Overview

Affected version of github.com/bitly/oauth2_proxy are vulnerable to Open Redirect. The Bitly oauth2_proxy in version 2.1 and earlier was affected by an open redirect vulnerability during the start and termination of the 2-legged OAuth flow. This issue was caused by improper input validation and a violation of RFC-6819