Cross-site Request Forgery (CSRF) Affecting github.com/bitly/oauth2_proxy Open this link in a new tab package, versions <2.2


0.0
high
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMBITLYOAUTH2PROXY-50015

  • published

    28 Mar 2017

  • disclosed

    28 Mar 2017

  • credit

    Unknown

Overview

Affected version of github.com/bitly/oauth2_proxy are vulnerable to Cross-site Request Forgery (CSRF) during the authentication flow.