Improper Input Validation Affecting github.com/cactus/go-camo/pkg/camo package, versions <2.1.1


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
6.1 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMCACTUSGOCAMOPKGCAMO-523463
  • published 13 Nov 2019
  • disclosed 13 Nov 2019
  • credit Unknown

How to fix?

Upgrade github.com/cactus/go-camo/pkg/camo to version 2.1.1 or higher.

Overview

github.com/cactus/go-camo/pkg/camo is a HTTP proxy server with content type restrictions as well as regex host allow list support.

Affected versions of this package are vulnerable to Improper Input Validation. Insufficient content type validation of proxied resources in go-camo can allow a remote attacker to serve arbitrary content from go-camo's origin.