Authentication Bypass Affecting github.com/concourse/concourse Open this link in a new tab package, versions <6.4.1 >=6.3.0 <6.3.1


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMCONCOURSECONCOURSE-598373

  • published

    13 Aug 2020

  • disclosed

    13 Aug 2020

  • credit

    Unknown

How to fix?

Upgrade github.com/concourse/concourse to version 6.4.1, 6.3.1 or higher.

Overview

github.com/concourse/concourse is an automation system written in Go. It is most commonly used for CI/CD, and is built to scale to any kind of automation pipeline, from simple to complex.

Affected versions of this package are vulnerable to Authentication Bypass. Concourse, versions prior to 6.3.1 and 6.4.1, in installations which use the GitLab auth connector, is vulnerable to identity spoofing by way of configuring a GitLab account with the same full name as another user who is granted access to a Concourse team.GitLab groups do not have this vulnerability, so GitLab users may be moved into groups which are then configured in the Concourse team.