SQL Injection Affecting github.com/concourse/concourse/atc/db Open this link in a new tab package, versions <5.0.1


0.0
medium
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMCONCOURSECONCOURSEATCDB-174088

  • published

    2 Apr 2019

  • disclosed

    21 Mar 2018

  • credit

    Unknown

How to fix?

Upgrade github.com/concourse/concourse/atc/db to version 5.0.1 or higher.

Overview

github.com/concourse/concourse/atc/db is a container-based continuous thing-doer written in Go and Elm.

Affected versions of this package are vulnerable to SQL Injection. An Concourse resource can craft a version identifier that can carry a SQL injection payload to the Concourse server, allowing the attacker to read privileged data.