Open Redirect Affecting github.com/concourse/concourse/skymarshal/skyserver Open this link in a new tab package, versions <5.2.8 >=5.3.0 <5.5.10 >=5.6.0 <5.8.1


0.0
medium
  • Exploit Maturity

    Mature

  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMCONCOURSECONCOURSESKYMARSHALSKYSERVER-561050

  • published

    24 Mar 2020

  • disclosed

    24 Mar 2020

  • credit

    xtremerui

How to fix?

Upgrade github.com/concourse/concourse/skymarshal/skyserver to version 5.2.8, 5.5.10, 5.8.1 or higher.

Overview

github.com/concourse/concourse/skymarshal/skyserver is a module of Concourse CI/CD automation system.

Affected versions of this package are vulnerable to Open Redirect. The login flow allows redirects to untrusted websites. Note: Initial fix was released on v4.2.2, but an edge case fix was committed in 5.2.8.