Improper Access Control Affecting github.com/containerd/containerd/archive package, versions >=1.5.0 <1.5.4 <1.4.8


0.0
medium

Snyk CVSS

    Attack Complexity High
    User Interaction Required
Expand this section
SUSE
3 low
Expand this section
NVD
6.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMCONTAINERDCONTAINERDARCHIVE-1320090
  • published 20 Jul 2021
  • disclosed 20 Jul 2021
  • credit Unknown

How to fix?

Upgrade github.com/containerd/containerd/archive to version 1.5.4, 1.4.8 or higher.

Overview

github.com/containerd/containerd/archive is an an open and reliable container runtime.

Affected versions of this package are vulnerable to Improper Access Control. Pulling and extracting a specially-crafted container image can result in Unix file permission changes for existing files in the host’s filesystem. This bug does not directly allow files to be read, modified, or executed without an additional cooperating process.