Privilege Escalation Affecting github.com/containerd/containerd/cmd package, versions <1.2.0 >=1.3.0 <1.3.9 >=1.4.0 <1.4.3


0.0
medium
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMCONTAINERDCONTAINERDCMD-1047459

  • published

    1 Dec 2020

  • disclosed

    1 Dec 2020

  • credit

    Unknown

How to fix?

Upgrade github.com/containerd/containerd/cmd to version 1.2.0, 1.3.9, 1.4.3 or higher.

Overview

Affected versions of this package are vulnerable to Privilege Escalation. Access controls for the shim’s API socket verified that the connecting process had an effective UID of 0, but did not otherwise restrict access to the abstract Unix domain socket. This would allow malicious containers running in the same network namespace as the shim, with an effective UID of 0 but otherwise reduced privileges, to cause new processes to be run with elevated privileges.