Improper Access Control Affecting github.com/containerd/containerd/runtime/v1 Open this link in a new tab package, versions <1.4.11 >=1.5.0 <1.5.7


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMCONTAINERDCONTAINERDRUNTIMEV1-1728018

  • published

    5 Oct 2021

  • disclosed

    4 Oct 2021

  • credit

    Unknown

How to fix?

Upgrade github.com/containerd/containerd/runtime/v1 to version 1.4.11, 1.5.7 or higher.

Overview

Affected versions of this package are vulnerable to Improper Access Control in the container's root directories and some plugins. This may allow unprivileged Linux users to traverse directories and execute programs.