Man-in-the-Middle (MitM) Affecting github.com/containers/image/docker package, versions <3.0.0


0.0
medium

Snyk CVSS

    Attack Complexity High
    User Interaction Required
    Confidentiality High
    Integrity High
Expand this section
NVD
5.9 medium
Expand this section
SUSE
9 critical
Expand this section
RHEL
6.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMCONTAINERSIMAGEDOCKER-466422
  • published 10 Sep 2019
  • disclosed 9 Sep 2019
  • credit Miloslav Trmac

How to fix?

Upgrade github.com/containers/image/docker to version 3.0.0 or higher.

Overview

github.com/containers/image/docker is a package used within containers/image to work with containers' images

Affected versions of this package are vulnerable to Man-in-the-Middle (MitM). ‎