Improper Authorization Affecting github.com/containers/libpod Open this link in a new tab package, versions <1.7.0


0.0
high
  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMCONTAINERSLIBPOD-1072068

  • published

    11 Feb 2021

  • disclosed

    10 Feb 2021

  • credit

    Unknown

How to fix?

Upgrade github.com/containers/libpod to version 1.7.0 or higher.

Overview

Affected versions of this package are vulnerable to Improper Authorization. File permissions for non-root users running in a privileged container are not correctly checked. This flaw can be abused by a low-privileged user inside the container to access any other file within it, even if owned by the root user inside the same container. It does not allow to directly escape the container, though being a privileged container means that a lot of security features are disabled when running it. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.