Information Exposure Affecting github.com/containers/podman/v2/libpod package, versions <3.0.0-rc2


0.0
medium
  • Attack Complexity

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMCONTAINERSPODMANV2LIBPOD-1066236

  • published

    1 Feb 2021

  • disclosed

    1 Jan 2021

  • credit

    Unknown

How to fix?

Upgrade github.com/containers/podman/v2/libpod to version 3.0.0-rc2 or higher.

Overview

github.com/containers/podman/v2/libpod is an a tool for managing containers and images, volumes mounted into those containers, and pods made from groups of containers.

Affected versions of this package are vulnerable to Information Exposure. Rootless containers can receive all traffic with a source IP address of 127.0.0.1 (including from remote hosts). This impacts containerized applications that trust localhost (127.0.01) connections by default and do not require authentication.