Information Disclosure Affecting github.com/containers/podman/v2/pkg/env package, versions <2.0.5


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
RHEL
5.3 medium
Expand this section
NVD
5.3 medium
Expand this section
SUSE
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMCONTAINERSPODMANV2PKGENV-1040465
  • published 24 Sep 2020
  • disclosed 24 Sep 2020
  • credit Unknown

How to fix?

Upgrade github.com/containers/podman/v2/pkg/env to version 2.0.5 or higher.

Overview

github.com/containers/podman/v2/pkg/env is a Package for processing environment variables.

Affected versions of this package are vulnerable to Information Disclosure. When using the deprecated Varlink API or the Docker-compatible REST API, if multiple containers are created in a short duration, the environment variables from the first container will get leaked into subsequent containers. An attacker who has control over the subsequent containers could use this flaw to gain access to sensitive information stored in such variables.