Information Exposure Affecting github.com/containous/traefik/pkg/server Open this link in a new tab package, versions <2.1.4


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMCONTAINOUSTRAEFIKPKGSERVER-560394

  • published

    26 Apr 2020

  • disclosed

    16 Mar 2020

  • credit

    Unknown

How to fix?

Upgrade github.com/containous/traefik/pkg/server to version 2.1.4 or higher.

Overview

github.com/containous/traefik/pkg/server is a server package for traefik, a cloud native edge router.

Affected versions of this package are vulnerable to Information Exposure. It mishandles the purging of certificate contents from providers before logging.