Cross-site Request Forgery (CSRF) Affecting github.com/coreos/etcd/etcdserver package, versions <3.4.0


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMCOREOSETCDETCDSERVER-50067
  • published 26 Apr 2018
  • disclosed 25 Feb 2018
  • credit zelivans

How to fix?

Upgrade github.com/coreos/etcd/etcdserver to version 3.4.0 or higher.

Overview

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). An attacker can set up a website that tries to send a POST request to the etcd server and modify a key. Adding a key is done with PUT so it is theoretically safe (can't PUT from an HTML form or such) but POST allows creating in-order keys that an attacker can send.