N1QL injection Affecting github.com/couchbase/sync_gateway/db Open this link in a new tab package, versions <2.5


0.0
medium
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMCOUCHBASESYNCGATEWAYDB-451074

  • published

    27 Jun 2019

  • disclosed

    26 Jun 2019

  • credit

    Unknown

How to fix?

Upgrade github.com/couchbase/sync_gateway/db to version 2.5 or higher.

Overview

github.com/couchbase/sync_gateway/db is a horizontally scalable web server that securely manages the access control and synchronization of data between Couchbase Lite and Couchbase Server.

Affected versions of this package are vulnerable to N1QL injection. An attacker with access to the public REST API can insert additional N1QL statements through the parameters startkey and endkey of the _all_docs endpoint.