Authentication Bypass Affecting github.com/crewjam/saml/samlsp package, versions <0.4.3


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
RHEL
9.8 critical
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMCREWJAMSAMLSAMLSP-1052759
  • published 18 Dec 2020
  • disclosed 17 Dec 2020
  • credit Unknown

How to fix?

Upgrade github.com/crewjam/saml/samlsp to version 0.4.3 or higher.

Overview

github.com/crewjam/saml/samlsp is a package that contains a partial implementation of the SAML standard in golang. SAML is a standard for identity federation, i.e. either allowing a third party to authenticate your users or allowing third parties to rely on us to authenticate their users.

Affected versions of this package are vulnerable to Authentication Bypass. It allows an attacker to bypass SAML Authentication.

** Note: This is a duplicate of SNYK-GOLANG-GITHUBCOMCREWJAMSAML-1050998.