Signature Validation Bypass Affecting github.com/dexidp/dex/connector/saml package, versions >=2.1.0 <2.27.0


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
Expand this section
NVD
9.6 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMDEXIDPDEXCONNECTORSAML-1054834
  • published 4 Jan 2021
  • disclosed 29 Dec 2020
  • credit Juho Nurminen, Eric Chiang, Stephen Augustus, Márk Sági-Kazár

How to fix?

Upgrade github.com/dexidp/dex/connector/saml to version 2.27.0 or higher.

Overview

Affected versions of this package are vulnerable to Signature Validation Bypass. Disclosures of a few vulnerabilities impact users leveraging the SAML connector.