Arbitrary Code Execution Affecting github.com/docker/docker package, versions <1.3.3


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
NVD  critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMDOCKERDOCKER-50007
  • published 10 Dec 2014
  • disclosed 10 Dec 2014
  • credit Tõnis Tiigi

Overview

Affected version of github.com/docker/docker are vulnerable to Arbitrary Code Execution attacks. Docker 1.3.2 allows remote attackers to execute arbitrary code with root privileges via a crafted (1) image or (2) build in a Dockerfile in an LZMA (.xz) archive, related to the chroot for archive extraction.