Arbitrary File Write Affecting github.com/docker/docker package, versions >=1.6.0 <1.6.1


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMDOCKERDOCKER-50045

  • published

    5 Aug 2015

  • disclosed

    18 May 2015

  • credit

    Tõnis Tiigi

Overview

Affected version of github.com/docker/docker are vulnerable to Arbitrary File Write. Libcontainer 1.6.0, as used in Docker Engine, allows local users to escape containerization ("mount namespace breakout") and write to arbitrary file on the host system via a symlink attack in an image when respawning a container.