Arbitrary Code Execution Affecting github.com/elves/elvish package, versions <0.14.0


0.0
high

Snyk CVSS

    Attack Complexity High
    User Interaction Required
    Scope Changed
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMELVESELVISH-1658289
  • published 24 Sep 2021
  • disclosed 23 Sep 2021
  • credit Unknown

How to fix?

Upgrade github.com/elves/elvish to version 0.14.0 or higher.

Overview

github.com/elves/elvish is an expressive programming language and a versatile interactive shell, combined into one seamless package. It runs on Linux, BSDs, macOS and Windows.

Affected versions of this package are vulnerable to Arbitrary Code Execution. Elvish's backend for the experimental web UI (started by elvish -web) hosts an endpoint that allows executing the code sent from the web UI. The backend does not check the origin of requests correctly. As a result, if the user has the web UI backend open and visits a compromised or malicious website, the website can send arbitrary code to the endpoint in localhost.

References