Improper Input Validation Affecting github.com/etcd-io/etcd/wal package, versions <3.4.10


0.0
low

Snyk CVSS

    Attack Complexity High

    Threat Intelligence

    EPSS 0.09% (36th percentile)
Expand this section
NVD
6.5 medium
Expand this section
SUSE
5.3 medium
Expand this section
Red Hat
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMETCDIOETCDWAL-597477
  • published 6 Aug 2020
  • disclosed 6 Aug 2020
  • credit Unknown

How to fix?

Upgrade github.com/etcd-io/etcd/wal to version 3.4.10 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. A large slice causes panic in decodeRecord method. The size of a record is stored in the length field of a WAL file and no additional validation is done on this data. Therefore, it is possible to forge an extremely large frame size that can unintentionally panic at the expense of any RAFT participant trying to decode the WAL.

References