Incorrect Calculation Affecting github.com/ethereum/go-ethereum/consensus Open this link in a new tab package, versions <1.9.24


0.0
medium
  • Attack Complexity

    High

  • User Interaction

    Required

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMETHEREUMGOETHEREUMCONSENSUS-1045351

  • published

    25 Nov 2020

  • disclosed

    25 Nov 2020

  • credit

    Unknown

How to fix?

Upgrade github.com/ethereum/go-ethereum/consensus to version 1.9.24 or higher.

Overview

github.com/ethereum/go-ethereum/consensus is a package that implements different Ethereum consensus engines.

Affected versions of this package are vulnerable to Incorrect Calculation. It could cause miners to erroneously calculate PoW in an upcoming epoch (estimated early January, 2021). This happened on the ETC chain on 2020-11-06.

Note: This issue is relevant only for miners, non-mining nodes are unaffected.