Cryptographic Issues Affecting github.com/ethereum/go-ethereum/eth package, versions >=1.9.4 <1.9.20


0.0
medium

Snyk CVSS

    Attack Complexity High
    Integrity High
Expand this section
NVD
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMETHEREUMGOETHEREUMETH-1050861
  • published 13 Dec 2020
  • disclosed 13 Dec 2020
  • credit John Youngseok Yang

How to fix?

Upgrade github.com/ethereum/go-ethereum/eth to version 1.9.20 or higher.

Overview

github.com/ethereum/go-ethereum/eth is a package that implements the Ethereum protocol.

Affected versions of this package are vulnerable to Cryptographic Issues. A consensus-vulnerability could cause a chain split, where vulnerable versions refuse to accept the canonical chain.