Insecure Encryption Affecting github.com/foxcpp/maddy/internal/auth/shadow Open this link in a new tab package, versions >=0.5.0 <0.5.2


0.0
medium
  • Attack Complexity

    High

  • Privileges Required

    High

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMFOXCPPMADDYINTERNALAUTHSHADOW-1730570

  • published

    13 Oct 2021

  • disclosed

    12 Oct 2021

  • credit

    Unknown

How to fix?

Upgrade github.com/foxcpp/maddy/internal/auth/shadow to version 0.5.2 or higher.

Overview

github.com/foxcpp/maddy/internal/auth/shadow is a composable all-in-one mail server.

Affected versions of this package are vulnerable to Insecure Encryption via the auth.shadow module as it uses insecure MD5 hashes.