Remote Code Execution (RCE) Affecting github.com/george518/ppgo_job/controllers package, versions *


0.0
high
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGEORGE518PPGOJOBCONTROLLERS-1583892

  • published

    9 Sep 2021

  • disclosed

    9 Sep 2021

  • credit

    Pd1r of Chaitin Tech

How to fix?

There is no fixed version for github.com/george518/PPGo_Job/controllers.

Overview

github.com/george518/PPGo_Job/controllers is a timing task management system.

Affected versions of this package are vulnerable to Remote Code Execution (RCE) via the AjaxRun() function. When agent is running, an attacker can send crafted TCP data flow, which will be executed without limitations.

References