Log Injection Affecting github.com/gin-gonic/gin Open this link in a new tab package, versions <1.6.0


0.0
medium
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGINGONICGIN-550031

  • published

    19 Feb 2020

  • disclosed

    19 Feb 2020

  • credit

    junorouse

Introduced: 19 Feb 2020

CWE-117 Open this link in a new tab

How to fix?

Upgrade github.com/gin-gonic/gin to version 1.6.0 or higher.

Overview

github.com/gin-gonic/gin is a package that implements a HTTP web framework called gin.

Affected versions of this package are vulnerable to Log Injection due to improper sanitisation of user-controlled log output.

References