Arbitrary Code Execution Affecting github.com/go-gitea/gitea/modules/setting package, versions >0.5.5 <1.13.0-RC1


0.0
high
  • Exploit Maturity

    Mature

  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGOGITEAGITEAMODULESSETTING-1018894

  • published

    16 Oct 2020

  • disclosed

    16 Oct 2020

  • credit

    Niklas Goerke

How to fix?

Upgrade github.com/go-gitea/gitea/modules/setting to version 1.13.0-RC1 or higher.

Overview

Affected versions of this package are vulnerable to Arbitrary Code Execution. If Gitea is installed as documented, the user running git hooks has limited permissions on the system but Gitea does not enforce this. Neither the documentation nor the UI contains a warning that explains the consequences of the git hook feature and the associated privilege.

References