Arbitrary Code Execution Affecting github.com/gogs/gogs package, versions >0.5.5


0.0
high
  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGOGSGOGS-1018895

  • published

    16 Oct 2020

  • disclosed

    16 Oct 2020

  • credit

    Niklas Goerke

How to fix?

There is no fixed version for github.com/gogs/gogs.

Overview

github.com/gogs/gogs is a painless self-hosted Git Service.

Affected versions of this package are vulnerable to Arbitrary Code Execution. The git hook feature allows for authenticated remote code execution.

References