User Enumeration Affecting github.com/goharbor/harbor/src/core/api package, versions <1.8.6 >=1.9.0 <1.9.3


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGOHARBORHARBORSRCCOREAPI-536723

  • published

    3 Dec 2019

  • disclosed

    3 Dec 2019

  • credit

    Unknown

How to fix?

Upgrade github.com/goharbor/harbor/src/core/api to version 1.8.6, 1.9.3 or higher.

Overview

github.com/goharbor/harbor/src/core/api is a cloud native registry project that stores, signs, and scans content.

Affected versions of this package are vulnerable to User Enumeration. The issue is present in the /users API endpoint. This endpoint is supposed to be restricted to administrators. This restriction is able to be bypassed and information can be obtained about registered users can be obtained via the "search" functionality.