Improper Authorization Affecting github.com/goharbor/harbor/src/server/v2.0/handler package, versions <2.4.3 >=2.5.0 <2.6.0


0.0
medium
  • Attack Complexity

    Low

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGOHARBORHARBORSRCSERVERV20HANDLER-3026974

  • published

    18 Sep 2022

  • disclosed

    16 Sep 2022

  • credit

    Oxeye Security

How to fix?

Upgrade github.com/goharbor/harbor/src/server/v2.0/handler to version 2.4.3, 2.6.0 or higher.

Overview

Affected versions of this package are vulnerable to Improper Authorization due to improper validation of the user permissions when updating tag immutability policies.