Improper Access Control Affecting github.com/google/exposure-notifications-server/pkg/jwks package, versions >=0.19.0 <0.19.2 <0.18.3


0.0
medium

Snyk CVSS

    Attack Complexity Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMGOOGLEEXPOSURENOTIFICATIONSSERVERPKGJWKS-1296315
  • published 23 May 2021
  • disclosed 21 May 2021
  • credit Unknown

Introduced: 21 May 2021

CVE NOT AVAILABLE CWE-284 Open this link in a new tab

How to fix?

Upgrade github.com/google/exposure-notifications-server/pkg/jwks to version 0.19.2, 0.18.3 or higher.

Overview

Affected versions of this package are vulnerable to Improper Access Control. Import of incorrectly embargoed keys could cause early publication. This could allow for imported keys to be re-published before they have expired, allowing for potential replay of RPIs.

References