Privilege Escalation Affecting github.com/google/fscrypt/security package, versions <0.2.4


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Integrity High
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMGOOGLEFSCRYPTSECURITY-50084
  • published 29 Aug 2018
  • disclosed 22 Jan 2018
  • credit Unknown

How to fix?

Upgrade github.com/google/fscrypt/security to version 0.2.4 or higher.

Overview

github.com/google/fscrypt/security is a Go tool for managing Linux filesystem encryption.

Affected versions of the package are vulnerable to Privilege Escalation. It incorrectly restored primary and supplementary group IDs to the values associated with the root user, which allowed attackers to gain privileges via a successful login through certain applications that use Linux-PAM (aka pam).