Improper Access Control Affecting github.com/gorilla/handlers Open this link in a new tab package, versions <1.3.0


0.0
medium
  • Attack Complexity

    High

  • User Interaction

    Required

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGORILLAHANDLERS-540773

  • published

    6 Jan 2020

  • disclosed

    1 Nov 2017

  • credit

    Evan J Johnson

Introduced: 1 Nov 2017

CWE-284 Open this link in a new tab

How to fix?

Upgrade github.com/gorilla/handlers to version 1.3.0 or higher.

Overview

github.com/gorilla/handlers is a collection of handlers (aka "HTTP middleware") for use with Go's net/http package (or any framework supporting http.Handler).

Affected versions of this package are vulnerable to Improper Access Control. CORS is misconfigured to allow the server to reflect all origin headers. This may allow an attacker to make AJAX requests to vulnerable hosts through cross-site scripting or a malicious HTML Document, effectively bypassing the Same Origin Policy.