Information Exposure Affecting github.com/go-vela/compiler/template/native Open this link in a new tab package, versions >=0.1.0 <0.6.1


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGOVELACOMPILERTEMPLATENATIVE-1055439

  • published

    5 Jan 2021

  • disclosed

    5 Jan 2021

  • credit

    Matthew Fevold, David May

How to fix?

Upgrade github.com/go-vela/compiler/template/native to version 0.6.1 or higher.

Overview

github.com/go-vela/compiler/template/native is a provides the ability for Vela to render a templated yaml configuration into an executable pipeline.

Affected versions of this package are vulnerable to Information Exposure. An attacker can use Sprig's env function to retrieve server configuration information set in the Vela server.

References