Access Restriction Bypass Affecting github.com/go-vela/server/api Open this link in a new tab package, versions >=0.7.0 <0.7.5


0.0
medium
  • Attack Complexity

    High

  • Privileges Required

    High

  • User Interaction

    Required

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGOVELASERVERAPI-1244700

  • published

    11 Apr 2021

  • disclosed

    11 Apr 2021

  • credit

    Jordan Sussman

How to fix?

Upgrade github.com/go-vela/server/api to version 0.7.5 or higher.

Overview

github.com/go-vela/server/api is a Package api provides the handlers for the Vela API.

Affected versions of this package are vulnerable to Access Restriction Bypass. A malicious user may be able to use the injected credentials in the ~/.netrc file in order to access secrets.