Improper Authentication Affecting github.com/grafana/grafana/pkg/login package, versions >=5.3.0 <8.3.10 >=8.4.0 <8.4.10 >=8.5.0 <8.5.9 >=9.0.0 <9.0.3


0.0
high
  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGRAFANAGRAFANAPKGLOGIN-2950819

  • published

    15 Jul 2022

  • disclosed

    14 Jul 2022

  • credit

    HTTPVoid team

How to fix?

Upgrade github.com/grafana/grafana/pkg/login to version 8.3.10, 8.4.10, 8.5.9, 9.0.3 or higher.

Overview

Affected versions of this package are vulnerable to Improper Authentication which allows a malicious user, who has the authorization to log in via an OAuth integration that provides a login name, to take over the account of another user in the same Grafana instance.

Note: This is exploitable only if:

  1. the malicious user is authorized to log in to Grafana via OAuth

  2. the malicious user's external user id is not already associated with an account in Grafana

  3. the malicious user's email address is not already associated with an account in Grafana

  4. the malicious user knows the Grafana username or email of the target user