Authentication Bypass Affecting github.com/gravitational/teleport/lib/auth Open this link in a new tab package, versions <4.4.11 >=5.0.0 <5.2.4 >=6.0.0 <6.2.12 >=7.0.0 <7.1.1


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGRAVITATIONALTELEPORTLIBAUTH-1586251

  • published

    19 Sep 2021

  • disclosed

    19 Sep 2021

  • credit

    Unknown

How to fix?

Upgrade github.com/gravitational/teleport/lib/auth to version 4.4.11, 5.2.4, 6.2.12, 7.1.1 or higher.

Overview

Affected versions of this package are vulnerable to Authentication Bypass via SSH host certificates forgery.

Note: This is exploitable when using tsh with an identity file, or if an attacker is able to get the agent to connect to a cluster within their control. This vulnerability is fixed in versions 7.1.1, 6.2.12, 5.2.4 and 4.4.11 which are available on Github.