Improper Input Validation Affecting github.com/gravitational/teleport/lib/web package, versions <11.0.0-dev.6


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGRAVITATIONALTELEPORTLIBWEB-2960805

  • published

    3 Aug 2022

  • disclosed

    27 Jul 2022

  • credit

    Zac Bergquist

Introduced: 27 Jul 2022

New CWE-20 Open this link in a new tab

How to fix?

Upgrade github.com/gravitational/teleport/lib/web to version 11.0.0-dev.6 or higher.

Overview

github.com/gravitational/teleport/lib/web is a Privileged access management tool.

Affected versions of this package are vulnerable to Improper Input Validation due to missing token validation. The token value is provided via the HTTP request and inserted into the node-join script, which could allow an attacker to generate a node-join script with malicious code included.