Remote Code Execution (RCE) Affecting github.com/hashicorp/consul/agent package, versions <0.9.4 >=1.0.0 <1.0.8 >=1.1.0 <1.1.1 >=1.2.0 <1.2.4


0.0
high
  • Exploit Maturity

    Mature

  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHASHICORPCONSULAGENT-559114

  • published

    3 Mar 2020

  • disclosed

    27 Nov 2018

  • credit

    Unkown

How to fix?

Upgrade github.com/hashicorp/consul/agent to version 0.9.4, 1.0.8, 1.1.1, 1.2.4 or higher.

Overview

github.com/hashicorp/consul/agent is a distributed, highly available, and data center aware solution to connect and configure applications across dynamic, distributed infrastructure.

Affected versions of this package are vulnerable to Remote Code Execution (RCE) via script checks, given that The API is available on an interface that can be accessed over the network and ACLs are disabled or an ACL token is compromised.