Improper Input Validation Affecting github.com/hashicorp/consul/agent/consul package, versions >=1.8.1 <1.11.9 >=1.12.4 <1.12.5 >=1.13.1 <1.13.2


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
7.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMHASHICORPCONSULAGENTCONSUL-3031723
  • published 23 Sep 2022
  • disclosed 23 Sep 2022
  • credit Unknown

How to fix?

Upgrade github.com/hashicorp/consul/agent/consul to version 1.11.9, 1.12.5, 1.13.2 or higher.

Overview

github.com/hashicorp/consul/agent/consul is a distributed, highly available, and data center aware solution to connect and configure applications across dynamic, distributed infrastructure.

Affected versions of this package are vulnerable to Improper Input Validation when a specially crafted auto-config request allows a TLS certificate and ACL token to be generated for a node name not intended by the operator.