Improper Certificate Validation Affecting github.com/hashicorp/nomad package, versions <0.10.3


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMHASHICORPNOMAD-564511
  • published 7 Apr 2020
  • disclosed 31 Jan 2020
  • credit Unknown

How to fix?

Upgrade github.com/hashicorp/nomad to version 0.10.3 or higher.

Overview

github.com/hashicorp/nomad is a workload orchestrator that can deploy a mix of microservice, batch, containerized, and non-containerized applications.

Affected versions of this package are vulnerable to Improper Certificate Validation. It incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation.

References