Privilege Escalation Affecting github.com/hashicorp/nomad/client/allocrunner/taskrunner/template package, versions >=0.9.0 <0.10.6 >=0.11.0 <0.11.5 >=0.12.0 <0.12.6


0.0
high
  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHASHICORPNOMADCLIENTALLOCRUNNERTASKRUNNERTEMPLATE-1020824

  • published

    23 Oct 2020

  • disclosed

    22 Oct 2020

  • credit

    tgross

How to fix?

Upgrade github.com/hashicorp/nomad/client/allocrunner/taskrunner/template to version 0.10.6, 0.11.5, 0.12.6 or higher.

Overview

github.com/hashicorp/nomad/client/allocrunner/taskrunner/template is a workload orchestrator that can deploy a mix of microservice, batch, containerized, and non-containerized applications

Affected versions of this package are vulnerable to Privilege Escalation. A specially crafted Nomad jobspec can be used to escape the client file sandbox configuration.

References