Improper Input Validation Affecting github.com/hashicorp/nomad/command/agent package, versions >=1.0.0-beta2 <1.0.17 >=1.1.0-beta1 <1.1.12 >=1.2.0-beta1 <1.2.6


0.0
medium

Snyk CVSS

    Attack Complexity High
    Availability High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMHASHICORPNOMADCOMMANDAGENT-2400725
  • published 14 Feb 2022
  • disclosed 14 Feb 2022
  • credit Unknown

How to fix?

Upgrade github.com/hashicorp/nomad/command/agent to version 1.0.17, 1.1.12, 1.2.6 or higher.

Overview

github.com/hashicorp/nomad/command/agent is a package part of hashicorp's nomad.

Affected versions of this package are vulnerable to Improper Input Validation due to insufficient validation of user-supplied input within the HCL configuration, which allows anyone with access to Nomad’s API to submit HCL formatted jobs for parsing to return the equivalent JSON. This endpoint allowed a malformed HCL configuration to be evaluated, resulting in excessive CPU usage on Nomad server agents.