Privilege Escalation Affecting github.com/hashicorp/nomad/command/agent package, versions <1.1.14 >=1.2.0 <1.2.8 >=1.3.0 <1.3.1


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMHASHICORPNOMADCOMMANDAGENT-2858279
  • published 3 Jun 2022
  • disclosed 3 Jun 2022
  • credit Unknown

How to fix?

Upgrade github.com/hashicorp/nomad/command/agent to version 1.1.14, 1.2.8, 1.3.1 or higher.

Overview

github.com/hashicorp/nomad/command/agent is a package part of hashicorp's nomad.

Affected versions of this package are vulnerable to Privilege Escalation via the stanza artifact in submitted jobs onto the client agent host.