Access Restriction Bypass Affecting github.com/hashicorp/nomad/drivers/qemu Open this link in a new tab package, versions <1.0.14 >=1.1.0 <1.1.8 >=1.2.0 <1.2.1


0.0
medium
  • Attack Complexity

    Low

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHASHICORPNOMADDRIVERSQEMU-2309897

  • published

    5 Dec 2021

  • disclosed

    5 Dec 2021

  • credit

    Unknown

How to fix?

Upgrade github.com/hashicorp/nomad/drivers/qemu to version 1.0.14, 1.1.8, 1.2.1 or higher.

Overview

Affected versions of this package are vulnerable to Access Restriction Bypass which allows authenticated users with job submission capabilities to bypass the configured allowed image paths.