Man-in-the-Middle (MitM) Affecting github.com/hashicorp/nomad/drivers/shared/executor package, versions <0.12.12 >=1.0.0 <1.0.5


0.0
medium

Snyk CVSS

    Attack Complexity High
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMHASHICORPNOMADDRIVERSSHAREDEXECUTOR-1292337
  • published 14 May 2021
  • disclosed 14 May 2021
  • credit HashiCorp product security team

How to fix?

Upgrade github.com/hashicorp/nomad/drivers/shared/executor to version 0.12.12, 1.0.5 or higher.

Overview

Affected versions of this package are vulnerable to Man-in-the-Middle (MitM). Nomad’s bridge networking mode allows ARP spoofing from other bridged tasks on the same node.