Privilege Escalation Affecting github.com/hashicorp/nomad/nomad package, versions >=1.1.0-beta1 <1.1.4 <1.0.10


0.0
high

Snyk CVSS

    Attack Complexity High
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMHASHICORPNOMADNOMAD-1582943
  • published 7 Sep 2021
  • disclosed 7 Sep 2021
  • credit Unknown

How to fix?

Upgrade github.com/hashicorp/nomad/nomad to version 1.1.4, 1.0.10 or higher.

Overview

github.com/hashicorp/nomad/nomad is an easy-to-use, flexible, and performant workload orchestrator that can deploy a mix of microservice, batch, containerized, and non-containerized applications. Nomad is easy to operate and scale and has native Consul and Vault integrations.

Affected versions of this package are vulnerable to Privilege Escalation. The RPC layer allows non-server agents with a valid certificate signed by the same CA to access server-only functionality, enabling privilege escalation.