Information Exposure Affecting github.com/hashicorp/vault/builtin/credential/ldap Open this link in a new tab package, versions >=1.5.0 <1.5.6 >=1.6.0 <1.6.1


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHASHICORPVAULTBUILTINCREDENTIALLDAP-1052074

  • published

    17 Dec 2020

  • disclosed

    17 Dec 2020

  • credit

    Unknown

How to fix?

Upgrade github.com/hashicorp/vault/builtin/credential/ldap to version 1.5.6, 1.6.1 or higher.

Overview

github.com/hashicorp/vault/builtin/credential/ldap is a package ldap for Hashicorp.

Affected versions of this package are vulnerable to Information Exposure. Allows the enumeration of users via the LDAP auth method.