User Enumeration Affecting github.com/hashicorp/vault/builtin/credential/ldap Open this link in a new tab package, versions <1.5.6


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHASHICORPVAULTBUILTINCREDENTIALLDAP-1065970

  • published

    29 Jan 2021

  • disclosed

    29 Jan 2021

  • credit

    Unknown

Introduced: 29 Jan 2021

CWE-203 Open this link in a new tab

How to fix?

Upgrade github.com/hashicorp/vault/builtin/credential/ldap to version 1.5.6 or higher.

Overview

github.com/hashicorp/vault/builtin/credential/ldap is a package ldap for Hashicorp.

Affected versions of this package are vulnerable to User Enumeration. LDAP auth method allowed user enumeration which can lead to disclosure of users.